تحديث ووردبريس Fiasco – مجلة محرك البحث


أصدر فريق تطوير WordPress ، في سلسلة من الأخطاء ، تحديثًا خاطئًا جعل من المستحيل تثبيت مواقع WordPress جديدة. لقد أوقفوا إصدار التحديث مؤقتًا في محاولة لإصلاح هذا التحديث ، لكن ذلك خلق المزيد من المشكلات ، مما يتطلب تحديثًا طارئًا لإصلاح جميع المشكلات.

تحديث أمني غير صالح لـ WordPress 5.5.2

بدأ الفشل الذريع في 29 أكتوبر 2020 بتحديث روتيني يهدف إلى معالجة المشكلات الأمنية الحرجة. تم تصميم WordPress 5.5.2 لمنع حدوث مشكلات مثل انتحال الطلبات عبر المواقع وهجمات XSS (Cross Site Scripting) والمزيد.

لسوء الحظ ، قدم التحديث أيضًا خطأ تسبب في فشل تثبيتات WordPress الجديدة. إليك كيف أوضح WordPress الخطأ:

“WordPress 5.5.2 … يجعل من المستحيل تثبيت WordPress على موقع ويب جديد لا يحتوي على اتصال قاعدة بيانات مهيأ. لا يؤثر هذا الإصدار على المواقع التي تم فيها تكوين اتصال قاعدة البيانات بالفعل ، على سبيل المثال من خلال المثبتات بنقرة واحدة أو ملف wp-config.php موجود. “

لإصلاح هذه المشكلة ، توقف WordPress عن طرح الإصدار 5.5.2 على المزيد من المواقع. وذلك عندما تم نشر تحديث احتيالي تلقائيًا.

ميلادي

أكمل القراءة أدناه

تم إطلاق تحديث WordPress Alpha عن طريق الخطأ

وضع WordPress الفرامل على التحديثات الجديدة. ولكن بينما كان فريق WordPress مشغولاً بإعداد WordPress 5.5.3 لإصلاح الخطأ أعلاه ، بدأت تحديثات WordPress التلقائية مرة أخرى.

ولكن نظرًا لعدم توفر الإصدار 5.5.2 ، اختار نظام WordPress الآلي إصدار Alpha من WordPress لتنزيله وتثبيته في 29 أكتوبر. لم يكن الغرض من إصدار Alpha هذا هو التثبيت واحتواء المشكلات.

ووردبريس 5.5.3 أخطاء ألفا

كانت مشكلة تثبيت WordPress Alpha هي أنك أدخلت قوالب WordPress إضافية وقمت بتثبيت Akismet.

من المفترض أنه لا يوجد شيء خطأ في هذه القضايا. لكن الناشرين الذين يختارون عدم إزالتها سيضطرون إلى تحديثها باستمرار. إذا لم يتم تحديث هذه المواضيع ، فقد تشكل خطرًا أمنيًا في المستقبل.

بحسب ال إعلان WordPress:

“في وقت سابق اليوم ، قام نظام التحديث التلقائي لـ WordPress بتحديث بعض المواقع من الإصدار 5.5.2 إلى الإصدار 5.5.3-alpha. كان هذا بسبب خطأ ناتج عن الاستعدادات للإصدار 5.5.3.

كان الإصدار 5.5.3-alpha في هذه المرحلة مطابقًا وظيفيًا لـ 5.5.2 حيث لم يبدأ أي عمل تطوير في 5.5.3 ، ولكن ربما تم إجراء التغييرات التالية:

تم تثبيت القوالب “Twenty” الافتراضية كجزء من حزمة ما قبل الإصدار. تم تثبيت المكون الإضافي “Akismet” كجزء من الحزمة الأولية “.

ميلادي

أكمل القراءة أدناه

إلى صفحة ويب، على ما يبدو لإصدار Alpha ، تم إصداره في 29 أكتوبر 2020 ، على ما يبدو أنه تم تسميته بشكل خاطئ الإصدار 5.4.3. أقول بشكل خاطئ لأن WordPress 5.4 تم إصداره في مارس 2020 وليس هناك فائدة من الرجوع من WordPress 5.5 إلى الإصدار 5.4.

على ما يبدو خطأ 5.4.3 صفحة التحديث يحتوي على وثائق مماثلة للمعلومات المنشورة من أجل الإصدار 5.5.2

ووردبريس 5.5.3

التحديث الأخير ، الإصدار 5.5.3 إنه كل شيء كان من المفترض أن يكون 5.5.2 ، فقط بدون المشكلات المرتبطة به. يعمل WordPress 5.5.3 على إصلاح جميع المشكلات المقدمة في الإصدار 5.5.2.

أوضح WordPress:

“يعمل إصدار الصيانة هذا على إصلاح مشكلة تم تقديمها في WordPress 5.5.2 والتي تجعل من المستحيل تثبيت WordPress على موقع ويب جديد لا يحتوي على اتصال قاعدة بيانات مهيأ. لا يؤثر هذا الإصدار على المواقع التي تم فيها تكوين اتصال قاعدة البيانات بالفعل ، على سبيل المثال عبر المثبتات بنقرة واحدة أو ملف wp-config.php موجود.

إذا لم تكن تستخدم الإصدار 5.5.2 ، أو تم تعطيل التحديثات التلقائية للإصدارات الثانوية ، فقم بالتحديث يدويًا إلى الإصدار 5.5.3 عن طريق تنزيل WordPress 5.5.3 أو زيارة Panel → Updates وانقر فوق “Update Now”.

ماذا حصل

تم تقديم المشكلات من قبل فريق التطوير لعدم وجود وثائق رسمية حول كيفية إيقاف تحديث WordPress. هذا هو السبب في أن فريق WordPress أوقف التحديث بطريقة فتحت الباب أمام إصدار Alpha لبدء طرحه.

تم إصلاح هذه المشكلة حتى لا يتكرر هذا السيناريو.

بحسب المسؤول التفاصيل الفنية نقاط البيعر:

“… لن يتم ذلك مرة أخرى. يبدو الآن أنه الوقت المناسب لتوثيق الطريقة الصحيحة والسليمة “لإيقاف” عملية الإطلاق الجارية ، والتي لم تتم تجربتها من قبل. يعد إيقاف الإطلاق أمرًا بسيطًا جدًا إذا قاموا بإجراء التغيير الصحيح ، لذلك بينما كانت محاولتهم افتراضًا معقولًا ، فقد تبين أنها خاطئة.

نظام الإصدار معقد ومحاولة القيام بأشياء لم يتم توقعها وتوثيقها أدت إلى نتائج غير متوقعة. سيتم تحسين ذلك من خلال التوثيق وتحسين الشفرة وإدارة نظام الإطلاق نفسه “.

ميلادي

أكمل القراءة أدناه

تحقق من تثبيت WordPress الخاص بك

يُنصح الناشرون بالتأكد من تحديثهم إلى الإصدار 5.5.3. تحتوي الإصدارات السابقة للإصدار 5.5.2 على مشكلات أمنية ، لذلك من المهم جدًا تحديثها إلى أحدث إصدار.

لا يحتوي إصدار الصيانة لـ WordPress 5.5.3 على أي اعتذار عن المشكلات ، فقط “الشكر والدعم” لفريق التطوير لإصلاح المشكلات التي قدموها.



Related Posts

اترك رد